Sk

SkyCAD won't start

14 posts / 0 new
Last post
#1 SkyCAD won't start

When starting SkyCAD, I get the following error message:

If I say no, I get this message, and SkyCAD doesn't start:

If I say yes, I get this message, and the SkyCAD starting up circle, and I can click OK endlessly, but nothing else happens.

 

It was working yesterday, but I have notices a few times that when saving a file, I get an error message.  I wish I had written it down, something about file access conflict.  It always has worked on the second try. 

I was going to attach my environment folder, but the zipped file is  258MB.  Maybe I can email a dropbox link. 

Not sure what's going on, I still suspect there's some kind of file access conflict between Dropbox and SkyCAD.

 

 

Hmmm....

Thanks for posting on the forum.

We got your environment, and are currently tryig to resolve this.

We'll get back to you promptly.

 

Tim,

Tim,

Are you running the latest version 1.2.103?

I had some startup issues last couple days, but, so far is working ok with the new version

 

Phil

Ok!

Ok it seems an important system file within your environment has vanished.  Thanks to the time machine we introduced lately, we were able to recover the latest saved version of it.  We attached it to this reply.

You must place it under:

<Your SkyCAD Environment folder>\Standard Environment\

And as Phil pointed out, we strongly suggest you upgrade to the latest version, which fixes a saving bug that might very well be the source of your issue.

Take note that you should first replace the attached file in your environment prior to upgrading.

Let us know if it works out.

OK, it's working now, with

OK, it's working now, with version 1.2.103.20847

Can I suggest that SkyCAD starts a forum thread with new version announcements/change logs?  As far as I know, the only way to see if there's a new version is to download and see if it's a different filename.

thanks

we already have something in place.

We're glad to know you're back on your feet!  Thanks for letting us know.

Can I suggest that SkyCAD starts a forum thread with new version announcements/change logs?

We already have a mechanism in place.  Let us explain...

When a new version is released, we first make it available to new users and see how it goes.  No matter how sturdy our testing is, there is always a few issues that pass by without us noticing.  Allowing only new users to get access to the latest release allows us to identify and fix those issues prior to having all our users upgrade at the same time.  Otherwise we'd be faced with having all our users experiencing these issues all at once.

Once no more issues pop, we 'flip the switch' and each user gets a message when starting SkyCAD, letting him/her know that a new version is available.  In the case of this particular version, this should be done later today.

Rolling a new version has proven to be a delicate operation for which we must always proceed with precaution.  

I had the file access error

I had the file access error occur today again, and now I have the same problem with SkyCAD not opening.  Here's the error.

It happened when I was closing SkyCAD.  It asked me if I wanted to save the project, I said yes, got this error.  Then I tried again and it appeared to save and close normally.

Tried to upload the

Tried to upload the environment, but I get a "413 Request Entity Too Large" error.  File is 173MB, below it says files must be less than 512MB.  I'll send it by email again.

Hmmm....

Thanks for posting o the forum.

Then I tried again and it appeared to save and close normally.

Ok, just so we understand: as of now, SkyCAD is back and working normally, right?  Just want to make sure.

Secondly, this being an 'access denied' error would point to an issue that is external to SkyCAD itself.  But we'll enquire nonetheless...

Please get back to us to confirm if indeed SkyCAD is back to normal or if you need our help with this.

No, right now SkyCAD is not

No, right now SkyCAD is not opening, same as post #1.  Looks like the Environment Structure file is missing again.

Ok!

Ok, we should be able to get it back working, provided we have the time machine files.  If you haven't sent your full environment through another means yet, you can simply make a ZIP of the Time Machine sub-folder of the environment and attach it to a reply.  (Iy will be much smaller, so it should attach...)  Once we get it, we'll be able to send you the correct file to replace the Environment Structure File.

 

Ok, we got it.

We just got your full environment through yoru DropBox share.

We'll get back to you shortly.

Here you go!

Ok, here is the latest EnvironmentStructure file from your time machine.  We tested it and we were able to get SkyCAD started.  Place it teh folder:

D:\Dropbox\Pro Electric\SkyCAD\Standard environment\

Let us know if it works out.

thanks, it's working.  The

thanks, it's working.  The only thing that I can think of that would be conflicting would be Dropbox, which always syncs files when they change.  I've had it before with one other piece of software that didn't like dropbox.  Might try it for a while in a different folder location.