restoring original catalogue for a particular block

13 posts / 0 new
Last post
#1 restoring original catalogue for a particular block



So when i was initialy playing around with skycad and creating new blocks and catagories to suit my needs, it looks like i erased the catalogue for relays. is there a way to restore just this item?

so when I want to assign

so when I want to assign information from the catalogue to the individual relay for doing the panel layout, it just brings up this:


Instead of this for a limit switch for example:


How would I go about restoring the original?


Have you tried reinstalling?

Not sure, but it looks like you might have just deleted the relay catalogue parts, which would explain why the first screen shot shows and empty list.  If you haven't already, try reinstalling, which should at least bring back the out-of-the-box relays.  

That said, if you deleted te Relay class, and recreated it afterwards, then it's a different problem (which we can solve, but it will require more work, that's all...)

Please get back to us about that.

I think it was that i deleted

I think it was that i deleted the relay class and recreated it afterwards,


if i back up my environment, because i made new classes and blocks, and restore it after a fresh install, will not the same problem persist?

Yes, it will persist...

When you delete a class and recreate it later, although the two classes may carry the same name, their internal IDs are not the same, and that's why the old parts can't be properly loaded anymore.

Since the entire class structure is stored into a single file, a back-up and restore after a fresh install will not resolve anything.

What you need to do is attach the environment structure file to a reply to this topic, and we'll make sure the relay class and its property definitions all get their original IDs.  Once this is done, all should fall back into place (and you won't loose the classes you created.)

The file is located under C:\SkyCAD Environments\Standard Environment\EnvironmentStructure.SkyCadFile.



here you go Thanks

here you go


Ok, we're in it.

Thanks for uploading your environment structure file.  We'll update it and get back to you shortly.  

We suggest you do not create any new classes until then, as they will be lost when you replace your current environment structure file with the ones will have modified.

It's working fine here...

We have downloaded your environment structure file and it looks to us like the relay class is the original out-of-the-box one.  Its internal ID is the same, and the catalogue listing shows parts when we try to assign from catalogue.

Please check that you actually have part files in the folder: C:\SkyCAD Environments\Standard Environment\Catalogue\root class\work field classes\Component\Relay\, as that would also explain the behavior you are experiencing.

Let us know when you have a minute.

Just checked, that folder is

Just checked, that folder is gone!

what do you guys think, back

what do you guys think, back up environment and reinstall?

Just reinstalll

Ah!  That's a good news, as it's an easy fix.  Just reinstall on top of the current one, and all should fall back into place.

Let us know how it turns out!

WORKED! thanks

WORKED! thanks


Glad all is back to normal!

Thanks for letting us know!