Print Setup

20 posts / 0 new
Last post
#1 Print Setup

Is there an area to setup what prints? None of my added text or attributes are printing. 

Hmmm...

Thanks for posting on the forum.

Is there an area to setup what prints?
No. Please right-click on any of those texts/attributes that don't print, select Explore Text and check if the Printable property checkbox is checked.

Please let us know.

On second thought...

Please send us a screenshot of a text or attribute properties, like this:

Thanks!

Thanks,

Thanks,

I do not have the printable option available..

Sorry

Ah, of course, sorry, that is currently in the beta version.

Please do send us a screenshot of a text or attribute properties though.

Here you go

Here you go

Image: 
Aha!

Aha, we can see what the problem is. There is no Value property, which is actually what is displayed on the sheet, not the Name property. This is a common misunderstanding.

We guess that you must have accidentally hidden the Value property of the Text class itself. It would probably be most efficient if you'd send us a zip of your environment so we can a) make sure our assumption is correct and b) correct it for you.

This tutorial about backing up your environment folder will indicate exactly which folder we are talking about. (Note: only you and the SkyCAD staff will have access to your environment.  All other users won't even be able to see the file.)

Thanks, here you go

Thanks, here you go

Try this

Thanks.

Yip, it's as we suspected. We changed it back to default and it works now. Please follow these steps:

  1. Close SkyCAD if it is open
  2. Open Windows explorer (if you're using Windows) and navigate to this file (located on C:\ by default):
  3. "C:\SkyCAD Environments\Standard Environment\EnvironmentStructure.SkyCadFile"
  4. Move that file onto your desktop for now (you can delete it once the issue is confirmed fixed)
  5. Unzip and move the attached file into its place "C:\SkyCAD Environments\Standard Environment\"
  6. Open SkyCAD
  7. Add a text to a sheet, writing something in the Value property
  8. The text should appear on the sheet and print if you print the sheet

Please let us know if this works.

I added as you said but when

I added as you said but when opeing SkyCAD, I get an error...

Image: 
After restoring from the time

After restoring from the time macine, I have the same issue of course.

Oops...

Sorry, perhaps our instructions were not clear enough. OK, instead of replacing files, here's how to fix the problem yourself (it's actually quite easy):

  1. Go to the Catalogue Tools tab and select Open Catalogue Class
  2. Go to the Show tab and select Class List
  3. Find Text in the list. Click on it and click OK
  4. Go to the Show tab and select Property Definitions
  5. You will now find a Value property in the list. Click on it once so it's selected
  6. Scroll to the right until you find the column named Visible
  7. You'll find this box is mistakenly unchecked. Check it. That's all.
  8. To test, add a text to a sheet, writing something in the Value property
  9. The text should appear on the sheet and print if you print the sheet

Please let us know if this helps.

Thank you,

Thank you,

This worked and moving forward I can make this work for text but what do so that the TBX-X is visable? 

The TB location is entered into the Name, do I have to copy this into the Value so that it prints?

Please upload some screenshots

Sorry, we're not quite sure what you mean. Could you share some screenshots to elaborate?

Thanks in advance.

Sorry for the confusion.  I

Sorry for the confusion.  I uploaded 2 screen shots.  One is print view with the new changes to 1 of the text (havent changed all of them yet) and the other screenshot is my normal work view.  The TB location ( TB1.X )  is missing from the print view but I have the text printable.  I had to move my text from the Name to the Value but by default the TB location is in the Name.  

Hope this is more clear..

Image: 
'Show Empty Attribute Names' button is on

Ah, OK, thanks.

Opening SkyCAD using your environment that you uploaded earlier, we can see the issue. The root cause of this confusion is that you have the Show Empty Attribute Names button activated under the Drawing tab. This causes all the "hidden" text to become visible, however, this does not mean it will print. Someone had the same confusion as you and it is discussed in this forum discussion. Please have a look.

All you need to do is double click on each of those empty attribute names displayed on your sheet and copy/cut/paste the Name text to the Value property.

To check what will be printed before you print, de-select the Show Empty Attribute Names button under the Drawing tab.

Please let us know if you get stuck.

Thanks,

Thanks,

So this always has to be copied and pasted? I have 110 Terminals just in this small project.

Change the terminal symbol

Actually, you should change your terminal symbol:

  1. Right-click on a terminal symbol and choose Open Block
  2. Double-click on the text attribute
  3. Click on the Name cell, then Process property queries from the Home tab
  4. Cut the query therein and paste it into the Value property
  5. Close and re-open SkyCAD, opting to save the changes you made to the symbol

All your terminal symbols should be good now.

Please let us know if this helps.

Perfect! Thank you!  

Perfect!

Thank you!

 

You're welcome!

You're welcome!