Sk

How to change new class tag value

6 posts / 0 new
Last post
#1 How to change new class tag value

I created a new class called battery as i use batteries for Mobile robotics.

I have added a symbol into this class but when i insert im getting the PWS1 Tag and i want to change the behavior of this class to use BAT instead of PWS.  How can this be achieved?  Also i plan to change the default numbering scheme for components to be pprrTAG.  for example a battery on sheet 1 rung 4 would be 0104BAT

What Titleblock coordinates are you using?

Thanks for posting on the forum!

We'll address your Battery/power supply class issue later, but first let's address your tagging format.  We first need to know about the current settings you have.  Do your pages currently display columns of rung numbers? If it's the case, your default numbering scheme should already be 'pprrTAG'.  Are you saying it's not the case, and your components are all automatically numbered TAG<#>  (PB1, PB2, PWS1, etc.)?

We'll better be able to help you once we have this answer.

Thanks in advance!

yes i display two columns of

yes i display two columns of rung numbers as my default and the Tag format is still TAG<#> with the number incrementing with each device added.

Follow these steps.

Thanks for your precisions.

This answer to an existing topic shows the steps to follow, with some minor differences to apply to your situation.  In your case, make sure to select the 'Component' class instead of the 'Power' class, and assign the 'Component by rung numbering format' instead of the 'Wire by rung numbering format'.  

Let us know if this allows you to set your numbering correctly.  Don't hesitate if you need further explanations.

this seems to fix the

this seems to fix the numbering format but i have the same problem now as another member.  A multi conductor cable has all the same wire numbers assigned.  Ill go post there now.

Now about your Battery's tag...

Ok, we'll check it out on the topic you will create.

Now let's see about your battery tag not showing up as you'd like.  We'll start by verifying the settings of the Battery class you created.

- Start by making sure 'SkyCAD' is selected in the treeview on the left.

- Then click on the 'Catalogue tools' tab, and select 'Open catalogue class'

- From the displayed list, select your new Battery class, and click OK.

Now could you post a screen shot of your screen?  This will help us making sure your class settings are properly defined.

Thanks in advance!