Sk

Best settings to use for high DPI monitor

14 posts / 0 new
Last post
#1 Best settings to use for high DPI monitor

I am wondering if there are any settings to make the SkyCAD interface show up without a slight blur on high resolution monitors?

This occurs on a high-DPI monitor in Windows 10, 3840x2160 resolution with 250% scaling. It is difficult to show the issue with screenshots, but basically any application that isn't DPI aware will show with a slight blur.

I have also tried 100% scaling, but the menus are too tiny to use, or 1920x1080, but then everything on the PC is blurred not just dpi-unaware applications.

I've attached a screenshot of the Sysinternals tool that is recommended on https://support.microsoft.com/en-us/help/3025083/windows-scaling-issues-for-high-dpi-devices for checking DPI awareness.

This is an issue with a lot of applications, but I wanted to bring it to your attention as it may be an easy fix. Unfortunately many newer laptops and monitors are high resolution, this is a Lenovo ThinkPad X1 Extreme, and LG 27UK850-W external monitor.

 

Ok.

Thanks for posting on the forum.

The SkyCAD user interface uses anti aliasing on graphic rendering by default (which creates the 'blurry' effect you are pointing out), and this can not be changed in the current version.

We have noted your request and will include it in the broader project of the user interface improvement, which is one of our major project planned for next year.  (Here's another forum topic that got the same process as yours...)

Our priorities for now are to finish the features associated wit he Pro licence, which we should be done with during the year 2020.  The UI improvement is planned for the year 2021.

Thank you for your feeback, it is greatly appreciated!

Status on this feature

Hello. Because the year 2021 is coming to an end soon, what is the current status of this feature if may ask?

250% DPI scaling, Version 1.2

250% DPI scaling, Version 1.2.183

To be fair, I use HD monitors at my desk but my Laptop display is 4k, which is what I am on right now

Wo!

Thanks for posting on the forum.

In the 'Program files' folder of Windows, you should find a 'SkyCAD Electrical' sub-folder where SkyCAD executable and DLL files are located.  Simply delete (or rename) the file named 'SkyCadElectrical.exe.config' and start SkyCAD again to get back to the previous version display setting.

We'll try to figure out what's going on and fix this for the next iteration.

Thanks for letting us know about it.

Sweet that fixed it.

Sweet that fixed it.

FYI this is still happening

FYI this is still happening in 1.2.190.

The workaround does work but it is annoying having to do it every time I switch back to using my built-in laptop screen.

Yes.

FYI this is still happening in 1.2.190.

Yes, we are aware this is not yet fixed.  But we're working on it.

 

Ok thank you

Ok thank you

The next beta-version should behave better...

Ok we've uploaded a new beta-version that should give better results.  We tested with 175%.

There will most certainly remain some display quirks here and there though.  Please let us know about them and we'll fix them.

 

Cool I'll Download it and

Cool I'll Download it and give it a go.

I can make do, and guess what

I can make do, and guess what the hidden characters are (usually), but i don't think this is the intended behaviour. I've attached a generic example, but it happens in several instances. I don't expect there to be anything appear when i try to show i/o for a power supply, but there is some text that I can't read since it his chopped off at the top

Image: 
expanding tree view arrows

Also, the active zone for the > V arrows is very tiny for my high resolution screen.  it takes a lot of effort to get my mouse to hit the correct spot and turn them green.

my screen resolution is 3840x2160 at 250% scale.

Indeed...

Indeed such a screen resolution using 250% scaling makes it so SkyCAD is pushed to its limit.

The way SkyCAD adapts to scaling is fairly new, and is temporary while we put in place a better process.  But it will noy be in place before about a year from now unfortunately.