Automatically pair component with accessory

14 posts / 0 new
Last post
#1 Automatically pair component with accessory

Hi,

I would like to know if it is possible to automatically add an accessory to a component?

For exemple, I have the relay number CR-M024DC4L from ABB that I would like to pair with it's base CR-M4SS. Right now I need to add them one by one to be able to see the base in the BOM. 

 

Thank you

I actually would be

I actually would be interested in this as well. It would be nice if we could define "Sub-BOM" that we can reuse, or something like that.

Yes, it's possible!

Thanks for posting on the forum.

Great question. Indeed, when saving a component to catalogue the usual way, all accessories are removed prior to saving.

Here's one way to save a component to catalogue with the accessories bound to it:

  1. Open the component
  2. Go to the "Create/Add" tab, select "New accessory" and choose the type of accessory (relay in this case). You should see the accessory added.
  3. Expand the properties of the accessory and enter the details (save the accessory to catalogue if you wish)
  4. When you're done, select the parent component (the relay) and choose "Save" from the "Home" tab
  5. You should see "CR-M024DC4L saved to catalogue"

Now the component (CR-M024DC4L) has been saved to catalogue with the accessories (CR-M4SS) embedded.

Next time you assign that part number to a symbol from the catalogue, it will have the accessories already there.

I hope this helps!

By the way, we're working on taking this a step further and making accessory management much more intuitive by introducing an "Assemblies" feature. Stay tuned!

wire duct

 

Hy,

I try to do the same with wire duct covers, but it does not show in the BOM.

I dont have the option save the accessory to catalogue if you wish, as you said in point 3.

Image: 
Please try this

It seems to work for us for some reason:

Please try select the parent component (TYD1CPG6), then go to the Home tab and Save:

Please let us know how it goes.

wire duct

I tried but didn't seem to work. But I forgot to mention that I am working in a system.

Please upload a zip of your Standard Environment folder

Please upload a zip of your Standard Environment folder so we can take a look. This tutorial about backing up your environment folder will indicate exactly which folder we are talking about. (Note: only you and the SkyCAD staff will have access to your environment. All other users won't even be able to see the file.).

Please also let us know which project to look at.

We'll be able to check this out as soon as we get your environment.

Thank you!

Standard Environment folder

Hi ther is my  Environment folder.

Is it the correct environment?

Thanks for that. However, are you sure that is the environment you are using?

There is not valid EnvironmentStructure file in that environment (which would prevent SkyCAD from opening) and there are no wire ducts or wire duct covers saved to the catalogue.

Please double-check which environment your SkyCAD is using by expanding the properties of SkyCAD in the tree view.

I work in a shared work
I work in a shared work environment, (onedrive). I believe that the first file I gave you has a problem, here is my environment again.

The projet i working in is: VDS_Poste de surpression.

We see

Thanks. We were able to see and reproduce the problem you described - the wire duct accessory is not showing up in the BOM. It's a bit mysterious to us, but we're working on it!

We'll get back to you soon.

Thanks for your patience.

Got it

The wire duct cover class you created has the Quantity property set to the Length property, but there is no Length property.
Everything worked once we created a Length property (which we set to ‘Measurement’ type):

Please let us know if this helps.

 yes it works thanks, now it

 yes it works thanks, now it is displayed in the bom. But it is possible to automatically make the cover have the same length as the wire duct in the BOM? (i dont want to have to put the layout of the cover in my backplane layout)

Image: 
Next version. Until then, here's a better workaround

Thanks for letting us know that works.

But it is possible to automatically make the cover have the same length as the wire duct in the BOM?
In the next version update yes. Unfortunately you'll have to wait until then.

In the meantime, we have a workaround for you so that you don't have to physically lay out the cover onto the backplate layout. The workaround is a little clunky, but it's better than laying out the cover.

Show the wire ducts and their accessories in the tree view.

From there you can expand the properties of each wire duct and accessory (wire duct cover) and edit the length of each wire duct cover to match the length of the wire duct it belongs to.

Again, this is just a workaround until we can supply a new version where the length of the wire duct cover can automatically match the length of the wire duct it belongs to.

We hope this helps.